Reply to post:

Wanted that Windows 10 update but have an Intel SSD? Computer says no

Anonymous Coward
Anonymous Coward

I'm running a Samsung SSD 850 EVO 250GB as my Windows 10 drive, and I've had to repair it at least 5 times during the last two weeks (not even once before 1803).

Large file copies sometimes hang and one by one the other running processes subsequently freeze. The machine becomes unresponsive and either BSODs with CRITICAL PROCESS DIED, or I have to use reset button. Sometimes the reset will not boot, and I have to power down the machine completely to get it to load.

The above sometimes corrupts the SSD and I have to fix that before it boots properly.

I've tried a complete reinstall, inplace and after reformat, but the problem continues.

I've checked memory, the SSD and its' firmware, my HDDs, my PSU and everything else I can think of. All that's left to blame is build 1803.

The only hardware issue I have in Device Manager is that my onboard Realtek driver saya it's working properly, but I get no sound. Using the Microsoft High Definition Driver works, but I've had to jump through hoops to get it to persist. (I've not tried the Realtek build 1709 driver), but expect that to work since it did before.

I've upgraded all the Device Drivers manually to latest versions, mostly Intel. (My Asus Prime 270-K is frunning an Intel CPU).

Whatever the SSD issue is, it's not just Intel and Tochiba SSDs getting borked by build 1803.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019