Reply to post:

If you're a Fedora fanboi, this latest release might break your heart a little

Anonymous Coward
Anonymous Coward

Anyway, after about 2 hours, the whole thing went tits-up... It turns out that the version of vagrant in Debian Stretch doesn't work with the version of VirtualBox for Stretch, so I had to add a repository from Hashi and update to the latest version and re-run the creation process again...

This kind of thing really annoys me. Distros' curation of packages is a kinda promise that it should all work, and it all gets messy when it doesn't.

This kind of cross-package version dependency is painful enough to manage as an ordinary user on platforms like Windows, where at least it's generally piss easy to install / uninstall any software you want. They have little hope of resolving them on most Linuxes

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019