Reply to post: Re: I wonder how well this would run Linux?

Surface Book: Microsoft to turn unsuccessful tab into unsuccessful laptop

Andy Non
Mushroom

Re: I wonder how well this would run Linux?

I don't know if it is an offence or not, but it was certainly offensive. It was originally an 8.1 laptop and I'd set it up to dual boot with Linux Mint. Both Windows and Linux had cohabited without problems. Even the Windows 10 update didn't mess up the dual-boot. It is only after several weeks after a number of Windows 10 automatic updates that it trashed the laptop. To be specific, after the updates had finished, the laptop would only reboot into Windows. It completely skipped the grub menu offering a choice of booting into Linux or Windows. I repeatedly tried rebooting but it went straight into Windows 10 every time. I was sure Windows was doing a full shutdown too (not that hybrid shutdown) as it I was being prompted for the hardware level power on password.

I went into the computer settings and discovered that all the UEFI settings had been enabled again. I tried turning them off then rebooted the computer again... straight into Windows. Checked the UEFI settings and they'd been turned on AGAIN. I was getting rather *annoyed* by this stage so disable the UEFI settings again and reinstalled Linux Mint from scratch, giving it the entire hard drive and blowing Windows 10 off the hard drive. I wasn't going to be bullied into using Windows 10 as my sole OS. From a few searches, it appears I'm not alone in experiencing Windows 10 trashing dual-boot and grub. Apparently it may be possible to reinstall grub and to regain access to the lost Linux boot, but I'm not prepared to play games with Microsoft only for them to do the same thing again at some point.

Anyway, the laptop now runs Linux Mint exclusively. Curious side effect now though; I have to reboot the laptop TWICE. The first (cold boot) fails after a few seconds and the laptop hangs. Then I do a soft reboot (Ctrl, Alt, Del) and it boots into Linux. I'd hazard a guess that the Windows update has messed with the firmware telling to look for Windows 10 on bootup... I read something about that a while ago on El Reg about the firmware being made to run a particular EXE on C:\Windows\somewhere that in turn was able to turn the UEFI stuff back on again etc. It of course now fails as there is no longer a drive C:

It is bloody annoying. I was quite happy to let Linux Mint and Windows 10 coexist on the same machine and to use each as required, Microsoft has forced the issue by taking complete control of the laptop, and that is NOT ACCEPTABLE. So, now Windows 10 is gone.

I had also been looking into buying a new Windows computer to make dual-boot with Linux Mint. In view of what has happened I will definitely not buy another Windows computer, instead I'll look into computers that are either guaranteed to work with Linux or come pre-installed with it.

It doesn't bode well for people wanting to install Linux on Windows 10 computers going forward.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019