Reply to post:

We tried using Windows 10 for real work and ... oh, the horror

Doctor Syntax Silver badge

Hmm. I thought I'd posted one comment here earlier but don't see it.

I installed an earlier build on a little Atom test box, partly to check on being able to set up FreeBSD dual boot.

It couldn't see either my printer (HP 3020 on a JetDirect box) or my NAS. Initially I couldn't even set the network mask so it could see their IP addresses. It could see my router & saw that it could be a media server (it shows it twice, once for each function) and it could also see my wireless AP. Updates allowed setting of network mask but no joy with printer or NAS.

One positive note was that it would allow me to install a lot of ancient Windows applications (I only have ancient versions of Windows stuff). There's a compatibility dialog to allow it to install as if it was one of several various earlier versions of Windows. This included Lotus Smartsuite (I said ancient) and Office 97 from a competitive upgrade disk (remember those?). It looks as if a lot of legacy programs might run.

I tried installing the current build from scratch. Same old installer bully-boy approach - blows away the existing boot loader but doesn't bother to check for other OSes.

Slow, slow, slow, slow, SSSSSLLLLLOOOOOWWWWW. Not only could I have installed Linux in a fraction of the time, I could have installed Linux, FreeBSD and SCO one after the other - and IIRC SCO was a really long-winded install.

It still doesn't find anything extra on the network automatically. I managed to set the network drive up going through the old settings window which is accessible as a sort of footnote via the new flat version. Manual addition of the printer got as far as driver selection - it didn't have the driver but offered to look for it via Windows Update which was also slow etc & I knocked it on the head after a while. Eventually I downloaded the 8.1 driver from HP and that worked. I haven't tried using the scanner.

The tile part of the start menu can be got rid of. Just unpin each tile in turn and then resize the window. The rest of the menu is still cumbersome.

It looks as if it can be arm-wrestled into working but I won't be keeping it. For the limited amount of stuff that I occasionally have to use Windows for it'll be either the Win7 VM or even the W2K VM.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

SUBSCRIBE TO OUR WEEKLY TECH NEWSLETTER

Biting the hand that feeds IT © 1998–2019