Reply to post: Re: Obsolete? Upgrade?

Apple Watch WRISTJOB SHORTAGE: It's down to BAD VIBES

Major N

Re: Obsolete? Upgrade?

More than that, it requires an iOS device to work. You won't still be using your iPhone 6 in a decade. And I suspect that when the iPhone 8 comes out with iOs 10 or whatever,. it will have dropped support for the first gen Watch, to force the cultists to upgrade anyway.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019