Reply to post: Re: Not for older MACs

All Mac owners should migrate to OS X Yosemite 10.10.3 ASAP

P. Lee Silver badge

Re: Not for older MACs

That's true and it wouldn't be too much of a problem if Apple didn't clamp down on upgrades, which is a relatively new thing they do and the full effect of it hasn't worked its way through the system.

I'd love an MBA, but with an 8G limit there's no way. Its one thing to not be upgradable, its quite another to hold down the spec so you can't buy what you think you might need in the future.

I see Apple are still defaulting to 4G RAM. I wonder how many people are disappointed with their new mac? Oooh! A shiny new MBA with a 3.2Ghz i7 and ... 4G RAM? Non-upgradable?

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019