Reply to post: Re: Not for older MACs

All Mac owners should migrate to OS X Yosemite 10.10.3 ASAP

Ted Treen

Re: Not for older MACs

My Early 2009 MacPro is running Yosemite quite happily. It's a 6-yr old machine, and still does all I ask it to do, including quite heavy Photoshop work with 210Mb 14-bit TIFFS (Exported Raw files from my D800).

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019