Reply to post: Re: Since it's only Yosemite affected...

All Mac owners should migrate to OS X Yosemite 10.10.3 ASAP

spatulasnout
Alert

Re: Since it's only Yosemite affected...

Well, no?

In the "trusecdev" article linked in the fourth paragraph, the discoverer of the vulnerability states that it works on all versions back to 10.7.x, and conceivably earlier but he didn't have a 10.6.x version to test with:

https://truesecdev.wordpress.com/2015/04/09/hidden-backdoor-api-to-root-privileges-in-apple-os-x/

He also states in his discussions with Apple, that: "Apple indicated that this issue required a substantial amount of changes on their side, and that they will not back port the fix to 10.9.x and older."

And in the comment section of that article--despite one poster who erroneously believed Apple's patch applied to his older OS version--posters are confirming the exploit works on older OS versions, and that apple's latest patch indeed does not fix the problem on older versions.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019