back to article The Register Android App

This app is no longer available Android logo

COMMENTS

This topic is closed for new posts.

Page:

    1. TeeCee Gold badge
      Coat

      Re: "And the rest"

      I didn't know there was such a thing linguistically as a "royal us" until now.....

  1. DrXym Silver badge

    Some tips for sites

    Browsing the web with a tablet can be a frustrating experience. Not because the browser is bad or renders the content wrongly. It's because sites see that I'm using a tablet and implement some intensely annoying behaviour.

    With that in mind, here are some rules that all sites should follow.

    1. DO NOT open a popup every time I visit the site asking if I want an app to view the content I'm viewing right this instance. If I said no the last time then there is a 99.99% chance you're just annoying me by asking again.

    2. Instead, DO put a discrete "get our app" link somewhere in the main page, and potentially at the *bottom* of other pages where it can be ignored if not desired.

    3. DO NOT redirect the user to the "mobile" version of your website. Most tablets are more than capable of rendering the full site. Even most phones are. If you absolutely must inflict mobile on a user, use a heuristic, e.g. user agent & screen res, and ASK ONCE.

    4. DO remember this decision so future visits to the site pick the right site.

    5. DO put a discrete "switch to mobile" link somewhere in the main page / bottom of content where a user can switch to the mobile version.

    6. DO put a discrete "switch to desktop" link in the mobile site.

    7. DO NOT maintain a www. and m. version of the same site or different urls to the same content. There is no reason for this at all. Use a filter to redirect a user based no their expressed display mode to one HTML template or another. Two links just confuses everyone and makes it a nuisance to bookmark content.

    There.

    1. frank ly Silver badge
      Thumb Up

      @DrXym Re: Some tips for sites

      Thank you for saying what I've been thinking (with less technical detail) for the past two years. I get especially annoyed with ebay and Wikipedia who always initially deliver their mobile site to my 10" tablet.

      Having said that, I am pleased that 'The Independent' newspaper delivers its mobile version, because then I get just the article text, with no fancy layout bars, no adverts and no big pictures; with simple links to other articles underneath it. I've tried the main site and it's full of crud that I don't want to download or look at. I use the Google RSS news reader for my newspaper and other regularly updated websites.

    2. Joe Harrison Silver badge

      Re: Some tips for sites

      Offtopic for mobile but I would like to propose:

      8. After allowing me to view the site for only three seconds DO NOT pop up a content-covering box asking me to take a survey where I feed back my experience of how much I do or don't like your site .

      1. Cliff

        Re: Some tips for sites

        Another pet hate...

        9) When I have followed an external deep link to a specific article, the 'mobile' version, if it is to be served up at all, really should take me to the same target article. Some sites seem to dump you back at their front page when they decide you want the m. instead of the www. version of the site, and this is frustrating beyond belief.

    3. Anonymous Coward
      Anonymous Coward

      Re: Some tips for sites

      Dr Xym..some tips for sites....

      From the name and the title I was expecting something with an, erm, grown up and "east european" flavour.

  2. Sil

    Regarding Windows app

    I'm using the Register's Windows Phone app everyday but I uninstalled the Windows 8 version which was very disappointing. At the very least please add options for type size, the possibility to get black text on white background.

  3. Khaptain Silver badge

    Samsung Note

    As soon as I start the applicaiton, I get a nice

    "An application restart is required".

    I can get to the main screen, click on the articles and get to the comments section on "some" articles. On the others, this one for example, I get network errors ( which I think in truth means timeouts of some kind or other"...) and Yes I have a good network connection I can browse to this site without problem.

    Oh well, everyone has to start someone, I know a coder who is profusely sweating at this moment in time...

  4. El Presidente
    FAIL

    An application restart is required

    Yup, application restart confirmed here, too.

    Also, when access to comments fails the settings button doesn't work.

    Nexus 7 Stock Android 4.2.1

    1. Alain
      Thumb Down

      Re: An application restart is required

      Indeed, I get "an application restart is required" every bloody time I go back to the welcome screen from the app using the home key and want to enter it again. Then, 3 times out of 4, I'm greeted by an "Unfortunately, The Register has stopped"... and back to the welcome screen where I have to start the app once again. Won't stand this for long, the app is likely to be heading towards the recycle bin soon and me back to the mobile site, I guess.

      Ployer Momo9C tablet, Android 4.0.3 stock.

  5. jason 7
    FAIL

    Doesnt anyone do any bloody testing anymore?

    Yes its tedious and boring but it stops you looking a twat later on!

    1. Anonymous Coward
      Anonymous Coward

      Re: Doesnt anyone do any bloody testing anymore?

      why, sir, I do not understand. It IS testing, innit?

    2. Andraž 'ruskie' Levstik

      Re: Doesnt anyone do any bloody testing anymore?

      We are the testers. Who would be better at testing it than the people that use the site primarily?

  6. Lee Dowling Silver badge

    Can't say I'd use it.

    Can't you just provide an RSS feed, or decent CSS on the website? On the few occasions I might be tempted to keep an eye on The Reg from a phone, I'll just load up Opera thanks, even on my (apparently ancient) Galaxy Ace. No installs taking up more space than I have, no separate program to be security-audited (i.e. don't use it for a year and see if it breaks for others), no specialist hassle to see the content, and no waiting for the app to come out / be fixed / get updated.

    Like Slashdot, I'd just much rather you practised what you preached and did the right "IT" thing - just provide a website that isn't locked into a 1920x1600 viewing in only a particular web browser and was designed properly. The entire WAP generation passed us by because of exactly this - by the time people worked out how to do it properly, websites that hadn't bothered but just made their content more accessible actually out-performed and out-classed them. Hell, I've never even loaded up the BBC website on a mobile, even back in the WAP-compatible days, except to laugh at the technology. Just load up a "proper" browser, which isn't beyond the means of any modern device, or even an ageing smartphone, and look at the "proper" webpage.

    How about we forget the Android stuff and finally publish an AAAA record in your DNS, eh? But I guess you'll write at least another 10 "IPv4 is gone, everyone should scramble to IPv6" articles before that happens - just like Slashdot do about once a month.

    1. frank ly Silver badge

      @Lee Dowling

      El Reg does have an RSS feed, it has several. I've been using the main one for ages and it's _usually_ exactly up to date.

      http://www.theregister.co.uk/Design/page/feeds.html

      1. El Presidente

        Re: El Reg does have an RSS feed

        Still requires the reader to visit the page for the article (and the adverts)

        At least it does in Sparse RSS

  7. VictoriaStamps
    Alert

    Oh dear...

    So it restarts when you first start it. The settings don't work. It has to (apparently) explicitly load each article. And something is twirling at the bottom of the screen...

    Other than that it appears to work :-/

    1. Ocasta Studios
      Childcatcher

      Re: Oh dear...

      Once the settings work... you'll be able to turn on a full offline sync mode that'll download all articles for offline reading.

      Whilst we fix up the settings, if you quit the app and go back to it then the setting will work. Peculiarly this only happens on the app when installed via Google Play. Installing the build we submitted without using Google Play doesn't have this behaviour. We're investigating the bugger now!

  8. GBL Initialiser

    The link in the article for the Win 8 & iOS app greets you with a 404 error when followed from the mobile site.

  9. El Presidente
    Trollface

    Oi! Ocasta Studios

    I've developed a two character front end plugin for your amazing app:

    Cr

    That'll be £3000 please.

    1. Ocasta Studios
      Pint

      Re: Oi! Ocasta Studios

      Really app-reciate that! Send us your bank details and we'll get you paid.

  10. Shippwreck1

    Settings...

    In the top right corner there is what looks like a settings icon, however when I tap it, it does nothing... not sure if it's meant to be a settings menu or not...

    Also every time I open it I get a message saying the application needs to restart and then it exits and re-loads the app

    HTC One X+ Running stock Android 4.1.1

  11. Irongut

    Why?

    I've never seen the point of these website in a box apps. El Reg works perfectly in Android Chrome and if I want to download stories to read offline I can open them in tabs. I'm almost never out of wifi or 3G reception when I would actually want to read the site anyway.

    I tried the last Reg app and it was so bad I've never used a website in a box app since!

  12. Doogie Howser MD
    Joke

    Careful!

    The dude moderating this is called Phil Mitchell, so if you are having trouble distinguishing real life from soap operas, you might get two sweaty, balding cockney types coming around your house to give you a good old fashioned knuckle dusting. That being said, didn't one of them call the police in real life when his ex-wife beat him up? Hmm..quaking in my boots now? Not so much.

    Oh, and +1 for Google Currents, great suggestion for whoever said it.

  13. GregC

    And another thing....

    On the Nexus 10, in landscape, the loading screen is stretched and looks bloody awful....

    Screenie

    1. El Presidente
      FAIL

      Re: And another thing....

      Ditto the Nexus 7

    2. Anonymous Coward
      Thumb Up

      Re: And another thing....

      Thanks for the background image. I needed one of those.

  14. ShaolinMonkfish
    Mushroom

    Not good

    Like others - comments and settings not working for me. Network connection is fine thanks! Needs some work. Hard to believe this passed muster really.

    Also like others have said, if you're providing an "app" it's got to do more than just provide the web-in-a-box. Otherwise why bother. Pocket more than adequately provides my offline reading capabilities already.

  15. JDX Gold badge

    At least they named the developer who built this.

  16. Nick Ryan Silver badge

    ...and there I was thinking that HTML 5 offline storage could be a good solution to reading articles offline rather than (yet another) app.

    I'll admit that I haven't tried using this functionality in anger, only in noddy test environments. Apps can do smarter things though, such as fetching content in the background even when the browser is not running, but that tends to upset user's data plans.

    1. JDX Gold badge

      It works for Kindle...

  17. BenM 29
    FAIL

    Not good is an understatement

    Galaxy SIII - stock OS 4.0.0, kernel 3.0.15-1029495-user

    Installed ok,

    Needed an immediate restart on application startup.

    Settings gear does nothing

    Go to comment on this story "Check your network connection" dialog box displayed (if the network connection is dead why did it manage to load the story? and BTW its the same network connection over which I am posting this)

    Hit phone back button

    Returned to El Reg. app but page blank and no buttons work - other than the phone back button.

    Exit application

    Restart

    Rinse and repeat.

    Uninstalling.

    El Reg, you fail in product testing. Galaxy SIII isn't exactly uncommon and nor is 4.0.4 android.... though the latter may be amongst other commentards :)

    1. peter 45

      Re: Not good is an understatement

      Pretty much what happened on my Transformer. Blech.

  18. pwibble
    Unhappy

    Continental Commentards Not Welcome

    "This item isn't available in your country" at least in The Netherlands.

    Boo hoo... or is El Reg just proactively betting on a "No" vote in 2017?

  19. thecapsaicinkid

    I'd rather see the Reg appear in Google Currents(without going via Reader). I really don't understand why someone would want a different app for each site they visit.

    1. Anonymous Coward
      Stop

      You can add the feed in Google Currents.

      You can even add the whole article body too, with some clever Yahoo Pipes magic.. :-)

  20. Kubla Cant Silver badge
    FAIL

    Where?

    Immediately I read about this I went to Play Store and searched for "the register".

    There were two results shown in Apps: The Register (Unofficial Feed) , which described itself as "not maintained or updated", and (tee hee) The Moron Test . If it's the latter, I think El Reg should keep its opinion of its readers to itself.

    Can anyone explain how "the moron test" is a valid search hit for "the register"? I know they both contain "the", but I would have though that was a noise word.

    There were a further 12239 results in Apps, but I don't expect to live long enough to check them all. I guess I'll just stick to reading El Reg on a computer as nature intended.

    1. Anonymous Custard Silver badge

      Re: Where?

      There's a link to it at the end of the first line in the article.

      Or click here to go get it.

      That said given how many issues have been found in it, you may be better to hang on a bit?

  21. peter 45
    Meh

    Yuck

    Just tried in on my Transformer. Each time it opens, it requires a restart, It crashes on opening 'bout 30% of the time, and the opening splash is the wrong aspect ratio. Settings icon doesn't seem to work (but the refresh button next to it does). There is no arrow showing that a comment is in reply and the ttile in the reply message does not do "Re: <title>.

    Apart from that a nice simple app (for how many Megs?)

  22. Haku

    Font size

    One reason I dislike apps that are a replacement for a web browser to view content on a certain site is that they almost always have a fixed font size, and no pinch-zoom.

    1. Ocasta Studios
      Coat

      Re: Font size

      Oh if only the settings worked, you'd be able to adjust the font size there! Try quitting the app and opening it again, that'll get the settings working and you'll be able to tweak the text display.

  23. El Presidente
    Thumb Up

    After the update ...

    The %ages are gone, the settings cog button now works but I'm still unable to reply in *this* article's comments which is ironic, really, but at least the log in un/pw is now being retained.

    "Unable to Connect

    Please check your network connectivity and try again"

    Back button then takes me to a blank white page. Back button again takes me to the article.

    I am able to comment in other articles.

    1. Ocasta Studios
      Facepalm

      Re: After the update ...

      Doubly ironic, as the reason you can't read the comments on this article is the comments you posted earlier have broken the thread so the app can't read it. D'oh.

      We're working on a fix now. Hang tight!

      1. El Presidente
        Thumb Up

        Re: After the update ...

        "Doubly ironic, as the reason you can't read the comments on this article is the comments you posted earlier have broken the thread so the app can't read it. D'oh"

        LOL!

        Oh well, at least you're on the case, good humoured and honest about the issues :)

      2. Markl2011
        Joke

        Re: After the update ...

        "Doubly ironic, as the reason you can't read the comments on this article is the comments you posted earlier have broken the thread so the app can't read it. D'oh."

        It will be the signed byte you use to store the number of comments ;-)

      3. blapping

        Re: After the update ...

        Err... I thought all these bugs were mysteriously introduced by the play store submission process? In which case, why aren't they all being fixed in a single operation rather than lots of individual, well y'know, bug fixes?

        1. Ocasta Studios
          Boffin

          Re: After the update ...

          Not all the bugs were caused through Google Play, the %20 comment issue was our fault, and we've released a fix for that. Ironically that created a rather unfortunate second issue; any comments that had been made with the broken encoding the app produced, then couldn't be read by the app. This was due to the double encoding that occurred. Great fun, we've fixed that too and there'll be a second update soon.

          "The application requires a restart" message. This only became apparent once the app was installed via Google Play, When the app is installed through Play it can be opened from the notification bar's message 'The Register Successfully Installed' or the Google Play listing changes to [Open] instead of [Install]. When launched this way, Google has, Rather kindly, introduced a bug that then launches the main activity on top of the current app, causing it to be launched twice. Once from the notification and once from the app. To get around this, the app asks to restart, so it can relaunch and open the single activity. However, this was firing more often than it should on some devices, and not at all on others. We'd then end up with two activities running at once, which would cause some major irregularities, the main one being the setting button not responding to touch, as it didn't know what to do. We've put in some workarounds now, you shouldn't see the message again, and best of all, settings will work consistently!

          We've taken the forthcoming update as a chance to address some other feedback. The font size will change the article lists as well as the articles, syncing will be quicker and you'll be able to read comments on all articles (no more blank screen). Once you can get in to your settings I recommend turning on article syncing, it's pretty fast now!

          - Ben

  24. GregC

    Seems very l-a-g-g-y too...

    It should scroll nice and smoothly, especially on a N4 (everything else does...) but it's really very jerky. Not as bad as the old app, granted, but even so it feels like I'm back on Gingerbread....

    Also, as per El Presidente's post - following the update I also get the "Unable to Connect" error when I hit the comments button for this article specifically - others are fine.

  25. Dcope
    Thumb Down

    now unable to connect.....

    to comments over 3.

    Again just a full feed to currents would have been better.

  26. This post has been deleted by its author

Page:

This topic is closed for new posts.

Biting the hand that feeds IT © 1998–2019