Toshiba gets on my last nerve

This topic was created by James O'Shea .

Silver badge

Toshiba gets on my last nerve

About six years ago my mother bought a new laptop. Because I knew who'd have to support it, I recommended that she get a MacBook, or, failing that, a good (read not particularly cheap) WinBox. She got a Toshiba Satellite L505. Like all Toshiba Satellites, the L505 comes in a wide variety of versions. She did not get one of the higher-end versions. IIRC it cost somewhere south of US$400. It shipped with Win7.

So, of course, I got volunteered to support the thing. I maxed the RAM, I cleaned most of the pre-installed bumf off it, I put her apps and whatnot on it, when the time came I installed updates as necessary and made sure to keep Win 8/8.1 and Win 10 far, far, FAR away.

Over time she reported that it seems to be allergic to wireless networks, as in some days it just won't connect to _any_ wireless network. It's not the networks, as other devices can connect. Doing the turn off the WAP dance doesn't work, not that I expected it to, as other devices connect. Turning the L505 off and back on would work... most of the time. So last week turning the laptop off and then on stopped working. Plugging in an Ethernet cable worked, so she could have network access, but she wanted _wireless_ access. So I went around and tried a few things.

I got out my trusty D-Link DWA-130 USB wireless stick, which is getting a little slow and elderly now but which always works, and downloaded the drivers for it direct from D-Link's site (possible because Ethernet worked) and installed it... and it didn't work. Hmm. Some kind of conflict? I turned off the internal Wireless. Nope. I disabled the internal wireless at Device Manager. Nope. I got drivers for the internal wireless from Toshiba's site and stored 'em on a flash drive, then deleted the drivers for the internal wireless _and_ the D-Link and reinstalled the D-Link. Nope. I deleted the drivers for the D-Link and reinstalled the drivers for the internal wireless, restarted... Nope. I shut down the L505 all the way, restarted... nope. I restarted one more time, and while it was coming up, called Toshiba support. Apparently Toshiba 'Support' for out of warranty systems, such as a six-year-old laptop, comes in two flavours: US$100 for single-incident 'support', or $200 for a years worth of 'support'. I hung up... and had another look at the L505, which was, of course, connected to the WAP.

I resisted the urge to dance on the laptop and gave it back to mother.

0
0

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Forums

Biting the hand that feeds IT © 1998–2017