back to article Firefox 36 swats bugs, adds HTTP2 and gets certifiably serious

Mozilla has outfoxed three critical and six high severity flaws in its latest round of patches for its flagship browser. It stomps out memory safety bugs, exploitable use-after-free crashes, and a buffer overflow. Of the critical crashes, bad guys could potentially craft attacks targeting MP4 video playback through a buffer …

  1. Wensleydale Cheese Silver badge

    "El Reg search" now available in FF36

    Updated yesterday and so far no problems.

    With my browser on the main article here, I clicked in the FF search box and it suggested "El Reg search", which I accepted, and now it's there as an easily clickable vulture icon.

    1. Jad

      Re: "El Reg search" now available in FF36

      The "Fedex" website stopped working on some of our machines yesterday ... turns out the main fedex site's certificate was fine, but one of the frames ran on a site with a "bad" certificate.

  2. Sebastian A

    Have they stopped

    screwing with the UI? I'm utterly over "fixing" things with every update, or waiting days or weeks for addon writers to tweak things back to how I like them. I'd rather run an outdated copy than go through that frustration all the time.

    1. adnim Silver badge
      Thumb Up

      Re: Have they stopped

      I want my status bar at the bottom back.

      1. Blackbird74

        Re: Have they stopped

        Only thing I found for that is to install the extension "New Add-on Bar". Just wish they hadn't "improved" out of existence it in the first place.

        https://addons.mozilla.org/en-US/firefox/addon/new-add-on-bar/?src=api

      2. Looper
        Angel

        Re: I want my status bar at the bottom back.

        Try The Addon Bar FF extension...

    2. paulf Silver badge
      Alert

      Re: Have they stopped

      No they haven't My leap from 34.0.5 to 36.0 last night broke the search box.

      It used to be you select the search engine you want to use and that applies in all windows until changed.

      Now it uses the default (can be changed) at all times. To use one of the non-default search options you click from the selection of search buttons that appear when you type in the search box for the non-default you want. Not much help if you want to do lots of searching on your non-default search service.

      Thankfully Classic Theme Restorer already had a fix for this which I turned on and reverted to the old behaviour.

      I completely agree that it shouldn't be necessary to run an add-on to fix Mozilla's continuing UI train crash but CTR does seem to do a good job of fixing 99% of the problems IME.

      1. Elmer Phud Silver badge

        Re: Have they stopped

        "No they haven't My leap from 34.0.5 to 36.0 last night broke the search box.

        It used to be you select the search engine you want to use and that applies in all windows until changed."

        Oddly enough, I did an update on a Vista machine yesterday (ancient battered lappy that is just a toolbox) and today on a W8 lappy.

        The Vista one screwed over the search box yet the W8 one is fine (maybe they fixed it)

      2. Anonymous Coward
        Flame

        @paulf - Re: Have they stopped

        Mozilla Help on Search says :

        Access all your favorite search engines conveniently through Firefox's built-in Search bar.

        Well, "conveniently" is a good description of how it was. Now it is just fucking annoying.

        Dumb, dumb, dumb, dumb, dumb.

        1. Anonymous Coward
          Anonymous Coward

          Re: @paulf - Have they stopped

          OK, I'd like to downgrade my status to just 'mildly annoyed', as I have now discovered that setting

          browser.search.showOneOffButtons to false

          in about:config reverts to the older style.

          Would have been nice to have a more user friendly way of doing it, mind.

          1. Richard 12 Silver badge

            Re: @paulf - Have they stopped

            That's because the guy in charge of the UI is an insane control freak who has no understanding of his users at all.

            He needs to be fired, he's a bloody idiot.

          2. Wensleydale Cheese Silver badge

            Re: @paulf - Have they stopped

            "browser.search.showOneOffButtons to false

            Thanks very much. That works a treat.

            I needed to restart FF for it to take effect.

    3. Paul Shirley

      Re: Have they stopped

      The ui vandalism is up there with win 8. Tried a vanilla install yesterday while trying to fix the plugins 36 broke and it took a couple of minutes trying to guess where the About menu was hidden. They've evolved the ui past useless into wtfville. I dread the day they break the addons that restore sense to the madness.

    4. Anonymous Coward
      Anonymous Coward

      Re: Have they stopped

      yes, it's screwed as much as humanly possible. Until the next release, that is. Due in 2 weeks or something :(

      1. Dan 55 Silver badge

        Re: Have they stopped

        I think moving the prefs window into the browser page is going to be officially on the next release.

        It's in the current one too if you twiddle browser.preferences.inContent in about:config. It's bloody awful, I put it straight back in its box.

        I put up with it because it's the most configurable, extendable, and private browser there is but they are trying my patience.

    5. This post has been deleted by its author

  3. Yet Another Hierachial Anonynmous Coward

    Problems with XP?

    Have FF performed an auto-update for peeps? My g/f rang last night to say her FF had died - just comes up with "fire fox has encountered a problem and has to close" message. Spent 2 1/2 hours on the phone trying to upgrade, re-install, uninstall, reinstall, all with same result.

    Not sure what version she had as I don't run FF, but it apparently worked fine the night before, the only version their website provided easy access to was 36, and I had no idea that it was brand new. Will now look for an older version to install over the weekend and make sure auto-update is off.

    Yes, i hate auto-updates and manufacturers who are consistently "fiddling" with things like UI just because they think it "looks" better in theior PFY world - I spend years tweaking UI's to get them as I like and they just go and trash that in one swift move - yes Opera I'm looking at you (amongst others)

    1. Paul Shirley

      Re: Problems with XP?

      To save everyone 20s searching ;)

      https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/35.0.1/

      1. Yet Another Hierachial Anonynmous Coward

        Re: Problems with XP?

        Until I saw El Reg article this morning I had not even given a moments thought that Firefox may have been the cause of the problem. I had assumed it was a local computer problem and went down that avenue of attack. After reading the article and commenting I too have done some searching so have a few options open for the weekend.

        And yes, I know it's an XP box, but as an artistic.creative type she has a lot of bespoke software installed, all of which would need re-installing, upgrading, re-licencing, etc, at great cost and effort, not to mention loads of phone calls for the next 6 months - where has this option gone - why can't I do this anymore, etc...... For a roughly 10 year old machine, dual core 3gig processor, 4 gig ram and about 5 terabyte of storage it's still pretty hot and there are no painless routes to upgrade....

    2. Dan 55 Silver badge
      Stop

      Re: Problems with XP?

      Two and a half hours on the phone? TeamViewer, for the love of God!

    3. mark jacobs
      Thumb Up

      Re: Problems with XP?

      Totally agree with you about Opera and Firefox. I also had the same gripes about Chrome and its awful propensity to hook you up to all and sundry just because you're registered. Opera seems the least of all evils ATM! Safari is too crashy.

  4. Reg T.

    But did MOZILLA

    tell you how to disable WebRTC?

    1. F0rdPrefect

      Re: But did MOZILLA

      Set media.peerconnection.enabled to false in about:config

  5. BlartVersenwaldIII
    Alert

    Vacateth thine lawn

    You could always install Pale Moon to both disable webRTC and get a more sane interface that suits us ye olde folke more betterer.

    1. Anonymous Coward
      Anonymous Coward

      Re: Vacateth thine lawn

      Not yet available on the SOS.

      (Supreme Operating System)

      ?

      ok clue, Newton?

      ok another clue

      Pomme

      Ok need 100 down votes Lab Rats

  6. TheBigCat

    Color management

    I have a wide color space monitor and haven't gotten color space management to work correctly since version 28. Does any one else have that problem?

    Bill

    1. Anonymous Coward
      Anonymous Coward

      Re: Color management

      Good question. Works for me, on Linux at least. Check your about:config - if you have old custom settings for gfx.color*, try the defaults.

      1. TheBigCat

        Re: Color management

        Thanks, I have cycled through the possibilities with the gfx settings and it didn't work.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2019