Feeds

back to article Mozilla becomes latest to dump Mac OS X 10.4 support

Mozilla will ditch support for Apple’s aged Mac OSX 10.4 - AKA Tiger - when it releases the next version of its Gecko rendering engine. The open source browser maker plans to push out Gecko 1.9.3 later this year, and at the same time support for Tiger will be dropped altogether, even though the Mozilla Foundation estimates that …

COMMENTS

This topic is closed for new posts.

Page:

Stop

Let it go!

Technology moves so quickly but some people don't move with it. That is their choice but why should the rest of us miss out because some people can't or won't keep up?

There are plenty of people using Windows 98 still. Should the developers of the world make sure that these people are supported? Stop your iPhone development!! We have out of date stuff to support!

By the time 10.4 support is phased out by Mozilla how many people will still be using it? I remember a quite vocal but small group attacking Opera for not supporting OS9 ...

3
4
FAIL

Um OK?

By that logic are they dropping support for Windows 2000/XP and Server 2003?

I'll have to go back to Safari on my PPC mac, that will suck... well unless I want an unsecure browser.

Why don't they be honest and just say they can't be bothered to code for OSX because there is not enough users to be worthwhile. I mean sure I can take that just like there is no Java 1.6/7 for PPC mac and everyone is dropping support for it.

There is always Linux I suppose. What a joke.

2
2
Anonymous Coward

umm

"they can't be bothered to code for OSX "? What are you smoking, precisely?

No, they can't be bothered to support an old architecture, one that the manufacturer hasn't shipped for a while, too. That is not the same.

Only one of my OSX machines is still PPC, it only gets used for Serato Scratch Live, and is otherwise pensioned off. You can find some very good deals on x86 machines, if you look around too.

To be honest, if you can't tell the difference between not supporting an architecture or an OS, you might want to steer clear of trying Linux- you need better reading comprehension for that.

2
1
Silver badge

It's not PPC vs Intel

10.5 works on sufficiently fast PPC machines (G4 867Mhz per Wiki; nothing shipped below that since April 2004) and the original Intels shipped with 10.4.

I'll guess that it's a lot easier for Firefox to work with whatever APIs Apple added as of 10.5, them being much more in the habit than Microsoft of replacing and deprecating their own stuff.

1
0
FAIL

OS X 10.5 runs on PPC Macs

So you could upgrade to Leopard and have the 10.5-only Firefox, you know?

0
0
Stop

Shock, horror, software publisher drops support for obsolete OS

meh

Google will probably pull the plug on Mozilla real soon now, this is a sensible move to reduce support costs, and not so surprising really.

0
0
Silver badge
Linux

Apple Sucks?

“There is no need to do this; it's a short-sighted plan to avoid supporting well over a million users who are still running 10.4 for various reasons; i.e., they can't afford to upgrade their equipment; 10.5 and 10.6 drop or break features that work perfectly well in 10.4; that upgrading would require them to purchase new versions of software that works perfectly well under 10.4; or even that many people think both 10.5 and 10.6 suck.”

Mmmm... They could always run Windows XP or Linux or Solaris x86 on their overpriced Hardware. (That's why the OS is cheap and they don't want in on non-Apple boxes, not the driver support issues)

In reality Apple stopped having their own HW & SW with switch from Power PC and end of OS9 development. x86/x64 Macs are just Commodity PC parts and a Pretty GUI on a BSD ripoff. Both add nothing to Computer Science or Engineering, its Marketing. An upmarket Brando gadget.

2
6

And the rest

>Both add nothing to Computer Science or Engineering, its Marketing.

I would suggest that this the case for all computing kit bought by the average home or business user, be it PC/Windows or Mac. Advancing computer science is not what these people want but a reliable work or entertainment experience. The envelope is pushed by the back-room types who experiment. In this category I would count Linux developers most of the time.

Andrew Newstead

0
0
Troll

Somebody press 'escape' please...

No humans involved. Linux Trollbot. Turing test fail.

0
0
Grenade

Where do you get your data?

"x86/x64 Macs are just Commodity PC parts and a Pretty GUI on a BSD ripoff. Both add nothing to Computer Science or Engineering, its Marketing. An upmarket Brando gadget."

First off, it's not a BSD ripoff, it's an evolution of the NeXT operating system, which was itself based on FreeBSD years before, released in 1989 for christ's sake. That's like saying Windows 7 is based on DOS. True yes, but a meaningless fucking statement. In 10.6, very, very little of that old code remains, having been replaced by Apple's own Core architecture, and a whole new GUI, and it runs on the Mach 3 microkernel, not the BSD kernel.

next, the chips are not exactly commodity. Apple does not use the generic Intel retail parts you find in Dells and HPs, they're using the cutting edge (at time of release) Core Architecture, and they include the VT, x64, and additional features in ALL the processors in all the products, where you may find some pretty powerful, and cheap, Dell systems, they often lack VT, making them useless for power users and incapable of supporting XP mode under Windows 7. Apple does not use Celeron, Centrino, i3, or other crap processors pushed by their competitors.

The DVD, HDD, memory, video card, yea, that's all commodity stuff. Always has been (except some early Macs based on SCSI hardware). There are no NON-comodoty components anymore in those classes unless you're talking high end CAD components and minicomputer subsystems costing thousands.

The build quality, you can't argue that. Apple has always been tops. Dell tries to compete with their Adamo line, but it's HUNDREDS more than an equivalent Apple ($400-700 more for the same parts, which don't even go as high in spec as the same apple model offers).

Then there's the "extras" that get thrown in no one notices. Webcams, high quality (not tinny) speakers, back lit keyboards, bluetooth in all models, MiMo dual band 5/2.4GHz wifi instead of generic 2.4GHz N, IR port for a remote, TosLink 5.1 fiber audio support in the same jack as the regular headphone jack, extremes in weight reduction without sacrificing rigidity and durability, extended life batteries getting 7+ hours (and yes, it really will play an MMO for 5+ hours with the second GPU active, we do that all the time, it's not a bullshit ideal battery life marketing number, and it will surf the web for over 7 hours), slot load drives. Apple sells their "commodity" machines in most cases under the same price Dell's equivalent hardware sells for, excluding these features. Currently, you can not BUILD a 27" iMac cheaper even excluding the OS and all the "bonus" parts, nor can you do that with a Mac mini, and no one competes on performance and price with the MacBook Pro line until you get into high performance 16 and 17" alien ware machines (and those often still cost more than a Mac).

They back it up with industry leading warranty pricing (and a warranty you can buy up to a YEAR later and still get full support!), a support department that isn't strictly break-fix focused (they'll assist you with a process as quickly as help you diagnose a problem), a support department where everyone you talk to speaks English as their first language, a support department that CALLS YOU, on schedule, instead of you waiting on hold. Oh, and you can bring it in to any Apple store or local retailer and in a lot of cases get same day repair, next day usually worst case, no shipping your system off and hoping UPS doesn't screw it up and waiting a week or more for it's return.

Run Windows on the Mac, sure, it simply increases the available software base. You can not do the same on PC hardware, run OS X that is, and if you want something that's even half as nice as using iLife, or to get your hands on powerful software like Aperture, Film Maker Pro, and a slew of other professional Mac-Only titles, then you're screwed. Even running a VM is better on a Mac than on a PC, as the two become completely integrated in a single experience, and do not require switching back and forth between guest and host and dealing with syncing files between them.

OS X is not cheap. The UPGRADE is cheap. Apple does not sell OS X in a box for a very good reason, their support groups would be OVERWHELMED. They'd get to 3-4 times the user base in a year or two. They simply can not staff up fast enough to do that, and Apple is not willing to sell the OS without including their industry leading support. They're completely comfortable to have 20-40% annual growth. In fact, that consistent, yet impressive, growth is a foundation of their stock price as well. We can COUNT on Apple doing better every year, and that would not be the case if they opened the OS to the market (which they have previously stated publicly would come in around $329 without iLife and $399 with it. (aka not cheap).

Upgrading from 10.4 to 10.6 does NOT require new software either. Yes, to take advantage of some new features, yes, and if you have some 10.3 or older software they again, yes, an upgrade MAY be required (comparability mode works quite well though). If you have a PPC with 10.4, then yes, some new software may not run, but you are not required to upgrade to it. Then again, if you have 10.4 or 10.3 native software that for some reason is not 10.6 ready, and there's not a free patch to make it compatible, and it doesn't work in compatibility mode, then why SHOULD you complain about having to buy an upgrade for software you've had at least 4 years if not 5??? Good luck going that long on Windows, all but a few programs made the transition from XP to 7... many didn't make it from XP to Vista. Office 2004 works fine under OS 10.6. So Does QuickBooks 2005. iLife needs an upgrade, but that's why it's INCLUDED in the 10.4-10.6 upgrade pack (as opposed to the 10.5-10.6 $29 pack).

Firefox is also decidedly NOT dropping 10.4 as an OS, they're dropping PPC as a hardware platform (which includes most people who have not upgraded to 10.6, though MOST can upgrade to 10.5 and maintain support...) They're dropping support because JAVA did. The PPC user base on 10.4 is less than 20% of Apple's base at this point. Also, what IS available for it isn't exactly disappearing, nor is Mozilla dropping PATCH support, just dropping PPC from NEW RELEASES.

If you're still on a PPC, and still on 10.4, than just like any XP user with a 4-5 year old machine, you're WELL AWARE that you're stuck until you replace hardware. No One bought a PPC Mac other than a Mac Pro after March 2006 (unless they went for a deal and bough back stock). No Macs with PPC were sold at all after Aug 2006, and those were the Mac Pro, which was a very small percentage of their sales. That means EVERY computer just cut off by Mozilla is at least 3.5 years old, most are well over 4 years old. That is by no means an outrage.

Where was this pouring of hatred for Microsoft, who's in a few weeks cutting off people from online play who bough games for the xBox 360 as recently as CHRISTMAS, and the vast majority of games which are 2-3 years old?

Can't "afford" an equipment upgrade? It;s a 4-5 year old machine. If you had not planned to replace it by now, you can't afford A COMPUTER. Macs cost the SAME to replace as PCs, however, they happen to have amazing resale value. I sold a PPC based iMac 17" with 1GHz processor and 768MB orf RAM about a year ago, it was 4.5 years old at the time, and it sold for $750. $750 is $100 shy of a new MacBook White. That's not exactly expensive for a brand new notebook with far more horsepower. Yea, it's not a $300 netbook, but a netbook is NOT a PC, it's a Piece of Crap. No one who is used to editing video, playing games, and managing tens of thousands of photos is going to settle for a $500 piece of shit low end Core2 Dell with no GPU, let alone a Netbook. That's NOT an upgrade. If you really need a new mac for critical software, and 10.6, you can pick one up lots of places under $500. (refurb Minis or backstock).

4
2
Silver badge
Thumb Down

Apple Trollbot?

@Michael C: You could have just said "See Apple's marketing materials". That covers just about everything you said, inaccuracies and all.

1
4
Silver badge

Bah!

"Bring it in to ...local retailer...same day service"

Not the experience of my Brother-in-law. He found that when he turned in his patently broken due to naff, cheap construction methods "better" G4, the mac tech at a certain now-defunct large national all-things-computer retailer - and there was only one mac tech, presumably because the service department bought the "it just works" hype - turned up on a schedule that made a typical cable TV technician look punctual. It took that individual three weeks before he even so much as cracked the case.

I'll give you that you might get same day service at an apple store (if you have a service contract: a colleague of mine got short shrift at an Apple store when they couldn't locate his). But I would tend to argue that you should expect to get turnkey products fixed in a short time at the store that sells the bally things.

0
0
Bronze badge

Apples are brilliant kit

(Usually, there are some exceptions, e.g. some early power pcs)

However, a big part of the justification for buying a Mac is that they last far longer than a PC.

We are now at the stage that some of them don't. not because the hardware is poor, but because software producers make them obsolete. And others you havr to keep spending on new OSes.

0
0
Silver badge
FAIL

A hindrance??

"a “hindrance” to adding modern technologies to the Firefox browser."

What a load of self serving BS. I'd love to know what shiny new low level OS system features are required by a bloody browser so that it can't be back ported to an OS version all of 5 years old. Perhaps they should dump XP while they're at it? Its 9 years old!

Why can't they just be honest and say that they can't be bothered to spend time testing it instead of coming out with some patronising lies?

4
2
Ed

Shiny new feature

Perhaps the shiny new feature was Intel chips?

0
0
Bronze badge
Dead Vulture

Old Tech - Old Software

Most of the users on 10.4 are still using FF3.5 which is now old yet they are complaining that the version that succeeds 3.6 will not support the OS they are using even though only 36,000 have moved to 3.6.

Mozilla obviously are thinking why spend time developing for 36,000!

If you don't move with technology you have to use the things that were developed for the technology that you want to use. I want FF on my Acorn Electron. I get that out occasionally (for nostalgia) therefore they should develop for it? I think not.

Gravestone because well it's old.

1
0

And another thing

While we're at it, can we please have an option to distribute Mozilla on vinyl? Not all of us are impressed with the fidelity of these compact discs, you know.

4
1
Happy

Re: And another thing

How about cassette tapes as I am keen to run FF 3.x on my ZX81!

2
1
Paris Hilton

Well, duh?

It's tons of legacy code, of course they want to get rid of it. I still run 10.4.. Suits me perfectly well and it is not really worth it to spend money on 10.5 when I plan to get a new machine with 10.6.x later this year anyway. So I guess I'll keep running the present version or Safari, the old barrell of molasses.

Regardless, they are just losing users this way.

2
1
Silver badge
WTF?

@ragarath

"If you don't move with technology you have to use the things that were developed for the technology that you want to use. I want FF on my Acorn Electron. I get that out occasionally (for nostalgia) therefore they should develop for it? I think not."

Theres a slight difference between porting to a 30 year old machine with ancient hardware never mind OS compared to porting to a few year old point version of a current OS on the same hardware don't you think?

1
1
Paris Hilton

Luddites

Software company drops support for an obsolete OS. A software company who provide their software for free......

10.4 users, I suggest you go and moan at someone who cares instead of whining your free lunch has been taken from you.

Paris, because she moans at a free ride.

2
0

Old tech, etc and 'running XP'

You do realise the comparison of XP (released in 2001) and Tiger/10.4 (released in 2005) is a little unequal?

It's entirely true that any machine forced to run OS X 10.4 due to hardware restrictions is at least 9 years old, but nevertheless 10.4 remains supported for security fixes by Apple and thus should continue to be supported by major open source products too.. Ditto Windows (Mozilla should continue to support Windows 2000, at least for the next few months).

Hardware limited to 10.4 is PPC based, so they can't run XP. The other reason to stick with 10.4 is if you've got a requirement for Classic, but I suspect that's an edge case - you could always dual boot. Various Unixes are also an option, but seriously that's not exactly the target market of a mac user, is it?

I feel a bit sorry for Mac users here because if they're not running a really creaky old G3, some of the kit is likely to be fast enough to run modern websites; it's not as if they're running a pentium (1) era machine where web browsing is now an exercise in pain.

3
1
Silver badge
FAIL

Upgrade FAIL

“There is no need to do this; it's a short-sighted plan to avoid supporting well over a million users who are still running 10.4 for various reasons; i.e., they can't afford to upgrade their equipment; 10.5 and 10.6 drop or break features that work perfectly well in 10.4; that upgrading would require them to purchase new versions of software that works perfectly well under 10.4; or even that many people think both 10.5 and 10.6 suck.”

You've answered your own argument - if you can't afford to upgrade to a new version of Firefox then don't upgrade - stick with the version you're using. You are obviously comfortable with the concept if you are still running 10.4.

0
0

Makes sense

If 1.5 million haven't even bothered to updgrade to 3.6, why should care about getting future version to work on 10.4 either?

Why should someone with a out of date OS feel the need to run the latest browser anyway?

Just get Leopard or Snow Leopard you arsewits

3
0
Anonymous Coward

bah

So my elderly powerbook won't run bloatfox ?

Gutted.

1
2

Personally...

I'm on Tiger with a G5, I'm not paying Apple £85 to upgrade to Leopard when they charge £25 to for the Snow Leopard installs (SL is only available for Intel). The machine was bought in 2005, it still perfectly functional. I will be using Opera under Tiger when I need to use flash (not often) and Fedora otherwise, for mythtv frontend and random internet use mainly.

I won't be spending that kind of money on an Apple product again because Apple and their associated suppliers take the piss out of their customers. I don't mind that software/hardware support gets dropped, but charging more for older versions of your software takes the piss. Also if I spend a grand on a computer, I expect it to be useable five years down the line.

0
0
Flame

Hang on...

"... but charging more for older versions of your software takes the piss" Why the fuck should you be rewarded for not upgrading to Leopard before 10.6 came out?! Leopard cost EVERYBODY ELSE that upgraded £85. What makes YOU a special case (other than the bleeding obvious)?! As a matter of FACT, Apple no longer directly sell 10.5! You took a gamble and lost. You thought you were being clever. Stop fucking crying about it! I don't know a SINGLE software company that'll sell you an older license for less. This is STANDARD business practice for software sales! I suppose that means you beef is with the retailers; and even then you're being unreasonable (UNDERSTATEMENT!!!). I have the same issue with XPtards who don't want to pay for a Vista Upgrade, but expect to pay the same price as everybody else for a Windows 7 upgrade!

"Also if I spend a grand on a computer, I expect it to be useable five years down the line." It IS useable! Leopard with run just fine and there are still a hell of a lot of apps that are Universal (PPC compatible)! As you have already found out, you can run Fedora on it; whether or not that is 'useable' is another debate, granted. What, did you expect everyone to still support you ad infinitum? Apple announced that the PPC would not be supported as of 10.6 IN 2006! Tough shit if you didn't pay attention! Stop being so melo-fucking-dramatic...

Out of bed on the wrong side again! Posts like that don't help. Grrrr.

0
0

10.4 != PPC restriction

I'm writing this on a seven year old PPC based Powerbook. It is currently running 10.5.8. Whilst you can't get 10.4 for an x86 based Mac, you most certainly can run 10.5 on a PPC based one. It is 10.6 that dropped PPC support.

One of the difficulties in support for older platforms is security. Dropping 10.4 support for a new major release is not unreasonable. But don't lose sight of the fact that one of the key reasons we like FF is that it provides a level of security and control of security that the other browsers simply don't and, it seems, won't provide. As much as the underpinning OS is a security critical component, for most people, the browser is too. That suggests that security support must, just like for an OS, be maintained for a much longer period. Lack of new features is simply part of the price of being stuck in the past. But lack of security support is evidence of a serious lack of sincerity on the part of any software provider. Free or not.

0
0
Alert

You're halfway there

I'm on a MacBook running 10.4. It's 10.3 that won't run on Intel-based Macs.

You're right about 10.5 working on PPC Macs though.

Surprisingly for a techie site, few people seem to be able to get their head around this!

0
0

You're not completely there, either.

10.5 works on some PPC systems, but not all as it needs 867Mhz of processor or better. Yes, it is possible to hack the installer to install anyway..

If you're running a G3 then it's probably too slow to view modern websites, but that doesn't apply to a half decent G4. You've got a system that's fully capable of running a modern web browser, but Apple deigns it insufficiently powerful to run 10.5.

It comes down to security fixes. Apple appears to have stopped fixing 10.4 (there's no actual statement that I can see, as opposed to MS' crystal clear lifecycle policies) so perhaps Mozilla feel as if they shouldn't bother either. The real question is not necessarily the next browser - clearly 3.7 is a nice to have, but Windows 2000 (still a supported product) is still stuck on an (up to date, security patched) IE 6..

I personally think Mac users should petition Apple for dropping support for a product that's only five years old, as opposed to the 10 and 13 year support of Vista and XP respectively. If OS X is supposed to be comparable to Windows, it should be held to similar support standards. Ditto commercial Unix. Once that's achieved (good luck) Mozilla should be given some gentle encouragement too..

I suppose I should double check Mozilla's security fix roadmap, but for the moment that's left as an exercise for the reader.

1
1
Bronze badge

G3 & G4

Leopard is quite easy to install on slow G4s, if you have a faster mac to hand. Just set the slow G4 into target disk mode and install Leopard to it as an external drive.

A G3 is OK on the web apart from bloated flash. However even Leopard supported G4s struggle with it. (I used to be able to use youtube reasonably on a G3, now a G4 struggles.)

0
0
Silver badge
FAIL

Mad

"If you're running a G3 then it's probably too slow to view modern websites,"

Although no doubt true that statement just seems nuts to me. The web must now just be full of fat flabby unoptimised code reliant on ever increasing CPU and bandwidth for a decent experience.

Jesus, it sounds like a Windows historical road map.

0
0
Coat

Cool....

Maybe they'll have time to fix the ever legioning caching problems that seem to pervade all versions of FF now - and maybe sift out the malware extensions they peddle without a seeming care.

Perhaps it just me (can't be) but FF is going downhill fast - not that I care about Tiger, OSX users should be legally obliged to run Safari and put their money where their mouths generally are.....

0
1
Flame

More Dumb logic..

What is it with you people?! "OSX users should be legally obliged to run Safari and put their money where their mouths generally are....." Two words; INTERNET EXPLORER. Two more; Numb nuts. That has got to be up there for the "Stupid troll comment of the year" category. Using your "logic" then Microsoft should follow suit and be legally obliged to run IE, Gnome users to run Epiphany and KDE users to exclusively run Konqueror. In fact, Mozilla should just stop making browsers altogether. I get that you are trying to suggest that Safari is "shit", but then so is Internet Explorer. FWIW Safari is absolutely fine on the Mac. Think it through next time...

0
0
Silver badge

Conflicted

The forward looking part of me says drop the PPC code base entirely and only support 10.6. The skinflint part that is writing this on a G4 iBook running 10.4 says 10.4 support should stay. I suppose in the long run this iBook will wind up running some flavor of linux and tucked nicely on a shelf being a perfectly good file dumbwaiter or some such and I'll finally have a shiny new 64 bit multi-core lapnetbook that can actually play HD video content. Good thing that's not today. As I always say, "live cheap or free".

What, no miser icon? What a cheap lot you are! (I'm so proud)

0
0

Firefox is Open Source ... so why not fork off?

You want later versions to work on your older kit .. then use the source Luke. After all that what it is there for. That's too hard? Then pay someone to do the port.

0
0
Stop

Do Apple still support 10.4?

I've never seen an official support life cycle document for Mac OS X, like MS have for their products, but I've got the impression that only the most recent two dot releases got updates - I certainly haven't seen any system updates for 10.3 for a long time!

0
0
Linux

Go OpenSource?

Okay, I don't have a Mac, so I don't know what I'm talking about :-)

But, from what I've read, the only people who are really gonna have problems with this are the people who are running the older PPC based Mac's and those running Intel-based Mac's who, for some reason or other do not want to upgrade.

So for the PPC group, there's a PPC version of Linux (Yellow Dog) which presumably will run up-to-date and future browsers. Not sure if there is something like Boot Camp, which will allow dual booting in order to still be able to run MacOS...

For Intel-base Mac's, well its easy. You can use Boot Camp or Parellels in order to run a standard Intel version of Linux, and then you can use an up-to-date browser. Sorted :-)

0
0
Paris Hilton

@ Paul 131

Sorry mate it's only been coded to work with a 48k, with rubber keys. Your going to have to upgrade your hardware....

Paris, because she knew once Amstrad got hold of Sinclair Research it was game over.......

0
0
Anonymous Coward

7 years?

I'd say it's a bit soon. Apple usually supports things for at least seven years, and it's a reasonable compromise. That would mean 10.4 support shouldn't be dropped just yet.

0
0

Gosh

"Meanwhile 36,000 Tiger-fanciers are running Firefox 3.6, which is Mozilla’s current iteration of its popular browser."

I'm one of only 36,000? That makes me feel special.

0
0
Unhappy

Business reasons for MaxOSX 10.4 and PowerPC

People who have purchased Apples paid a premium for their machine, so the discussion that people can't afford to upgrade their OS is really silly.

Paul 77 posts, "the people who are running the older PPC based Mac's and those running Intel-based Mac's who, for some reason or other do not want to upgrade."

The question is - what are those reasons?

- PPC with MacOSX 10.4 will run older MacOS9 software.

Some of this MacOS9 software is no longer available under MacOSX native (i.e. Adobe FrameMaker) and the need to access older documentation is critical for many businesses since there are no alternatives

- PPC machines are very stylish and people do not want to retire them

The older half-domed iMac with the silver arm holding the large flat screen runs with a fairly high-speed PowerPC processor and USB 2.0 - it makes a great little machine to stick in the corner. Many people buy used models, just because they like the styling, long after it was no longer sold.

- Dual 2.5GHz G5's with MacOSX 10.4 is a very viable platform

Many creative businesses are running very fast desktop platforms, like this, with dual 1080p capable monitors. When they have integrated their desktops with all of their software, they are most likely not interested in changing any particular aspect of their desktop until there is a business reason. Upgrading an OS without an underlying business reason, or for the reason af a web browser, is pretty foolish.

- Time and effort in upgrading all the software to a new OS release

When the existing platform works just fine, upgrading an OS may chain upgrades of other required business applications into hundreds or thousands of dollars. The downtime in debugging these types of upgrades and learning where old keyboard accelerator keystrokes have been moved to are such where many people wait until Christmas or Easter vacations to perform upgrades, so they have the time to work through the efforts. Many businesses don't bother until they decide to buy new machines, usually on a 5 year depreciation tax cycle.

Joe3 posts, "So you could upgrade to Leopard and have the 10.5-only Firefox, you know?"

Upgrading the OS for the purpose of a free web browser may lose accessibility to older paid software. Many people have/will decided to not go through this effort for a free web browser point release.

Apple's are not PC's that people buy for their kids to play games on. People who have businesses depend on them. As long as used models are available, these machines and MacOSX 10.4 will be used for a very long time.

(I am writing this from a MUCH OLDER Windows XP OS on a laptop. My business has not seen it fit to upgrade my desktop, so if Mozilla/FireFox decides that they are not going to support XP, well, FireFox will be no more - this is their decision because I suspect many people's desktop OS is not their choice, but determined by other factors.)

0
0
Bronze badge

re: Business reasons for MaxOSX 10.4 and PowerPC

I agree, except:

"People who have purchased Apples paid a premium for their machine, so the discussion that people can't afford to upgrade their OS is really silly."

Except those who bought before the recession and now have less free cash, and those who bought a second hand machine.

"Apple's are not PC's that people buy for their kids to play games on. People who have businesses depend on them. As long as used models are available, these machines and MacOSX 10.4 will be used for a very long time."

Second hand ones are.

0
0

Very good reasons not to upgrade

but why do you care tabout updating your webbrowser to the next version, which is not even in development yet, when you have so many valid reasons not to upgrade anything else?

0
0
Bronze badge

why do you care tabout updating your webbrowser

Security fixes for one thing.

0
0

Modernity

"If you're running a G3 then it's probably too slow to view modern websites"

Correct, assuming by "modern" you mean bogged down with flash and unnecessary javascript...

1
0

One person's unnecessary frippery is another's essential tool

Take google maps, for instance. I'll grant that sites like ebay possibly don't need to be quite so javascript infested. Flash is probably overused but for the most part it's javascript that's the essential tool. Friendly AJAXified websites are probably a net gain to progress even if they rule out some older kit.

I'm not sure what the tipping point is, as it's highly architecture/OS/compiler dependent, but it's clearly somewhat lower than the computer salespeople would like to admit. I reckon by the time 500MHz of G4 (especially dual) is reached it'd be more than sufficient, if perhaps not sparkling. 300MHz of pentium I/II clone and 200Mhz MIPS R5000 are not especially different : both are grindingly slow regardless of OS.

Of course there's a difference between usable and speedy. On a day to day basis I prefer to use rather more modern machines.

I wonder if anyone has done some sort of ongoing web benchmark with popular websites to determine the lowest genuinely usable configuration.

0
0
Stop

About that Apple Trollbot...

I don't own a Mac, don't use 'em and I don't like the UI that much. But I do appreciate that they're well made, well finished, functional products which are consistently among the most reliable (says Consumer Reports, at least)(Consumer Reports is the US equivalent of Which)

So we might have a trollbot recycling marketing materials but nothing he/she/it says is untrue. I still don't like 'em, though....

0
0
Unhappy

Panther rules

Shame really because 10.3 (panther) was the peak of Mac OS X. Before Panther there were many issues with optimizations. After Panther it gained a flavor-of-the-month-but-useless search tool and lots of bloat.

0
0
Paris Hilton

wtf!

So the fanbois that spank massive sums on a mac cant afford to upgrade the OS?

And they are complaining that a free product doesnt support there minority group?

I guess the cult isnt so full of shiny happy people anymore.

Paris, she used to people spanking massive sums!

0
0

Page:

This topic is closed for new posts.